April 29, 2025 15:02 BST
[Resolved] CSL Infrastructure Engineers have monitored the stability and confirmed that all services are now restored. The incident is now closed.
April 29, 2025 13:47 BST
[Monitoring] CSL Infra Engineer have monitored majority of the devices restored and we have received update from our MNO Telefonica as power issue in spain and Portugal largely been restored and a gradual recovery of service is expected.
April 28, 2025 21:16 BST
[Monitoring] Issues with telefonica sims belived to be due to the widespread power disruption across Spain due to the national major incident running in the country where a substantial amount of Telefonica infrastructure is based. CSL will monitor failure rates and keep this thread updated on the status page as we know more or see restoration.
April 28, 2025 21:05 BST
[Investigating] CSL has been made aware that some radio paths in webway devices with Telefonica sims are loosing connectivity via those sims. This is believed to be caused by the ongoing power outages across Spain and Portugal. We expect devices to recover again as electricity stability returns to the country over the coming days. Dual path devices will continue to signal via their other paths.